<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <meta name="google-site-verification" content="9f4nRUzJk0UTY2k2U2lN9MiIaI-HReD4LJ1Wq0vgpow" />
    <title>OBIEE 12c Catalog Validation: Command Line</title>
    <meta name="description" content="The old 11g method for running catalog validation is no longer available in 12c.
Check out how to perform a full catalog validation in 12c." />

    <meta name="HandheldFriendly" content="True" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="shortcut icon" href="/blog/favicon.ico">

    <link rel="stylesheet" type="text/css" href="/blog/assets/css/screen.css?v=3df933d700" />
    <link rel="stylesheet" type="text/css" href="//fonts.googleapis.com/css?family=Merriweather:300,700,700italic,300italic|Open+Sans:700,400" />

    <link rel="canonical" href="http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    <link rel="amphtml" href="http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/amp/" />
    
    <meta property="og:site_name" content="Rittman Mead" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="OBIEE 12c Catalog Validation: Command Line" />
    <meta property="og:description" content="The old 11g method for running catalog validation is no longer available in 12c.
Check out how to perform a full catalog validation in 12c." />
    <meta property="og:url" content="http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/" />
    <meta property="og:image" content="http://www.rittmanmead.com/blog/content/images/2017/06/1q1dx1-2.jpg" />
    <meta property="article:published_time" content="2017-06-23T13:49:32.000Z" />
    <meta property="article:modified_time" content="2017-06-23T13:49:32.000Z" />
    <meta property="article:tag" content="OBIEE12c" />
    <meta property="article:tag" content="catalog validation" />
    <meta property="article:tag" content="catalog" />
    <meta property="article:tag" content="errors" />
    <meta property="article:tag" content="command" />
    
    <meta property="article:publisher" content="https://www.facebook.com/rittmanmead" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="OBIEE 12c Catalog Validation: Command Line" />
    <meta name="twitter:description" content="The old 11g method for running catalog validation is no longer available in 12c.
Check out how to perform a full catalog validation in 12c." />
    <meta name="twitter:url" content="http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/" />
    <meta name="twitter:image" content="http://www.rittmanmead.com/blog/content/images/2017/06/1q1dx1-2.jpg" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Francesco Tisiot" />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="OBIEE12c, catalog validation, catalog, errors, command" />
    <meta name="twitter:site" content="@rittmanmead" />
    <meta name="twitter:creator" content="@ftisiot" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "Rittman Mead",
        "logo": "http://www.rittmanmead.com/blog/ghost/img/ghosticon.jpg"
    },
    "author": {
        "@type": "Person",
        "name": "Francesco Tisiot",
        "image": "http://www.rittmanmead.com/blog/content/images/2016/10/Ftisiot.jpg",
        "url": "http://www.rittmanmead.com/blog/author/francesco-tisiot/",
        "sameAs": [
            "https://twitter.com/ftisiot"
        ],
        "description": "OBI Tech Lead EMEA and Principal Consultant at Rittman Mead, OBIEE enthusiast, Speaker, Blogger, Trainer."
    },
    "headline": "OBIEE 12c Catalog Validation: Command Line",
    "url": "http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/",
    "datePublished": "2017-06-23T13:49:32.000Z",
    "dateModified": "2017-06-23T13:49:32.000Z",
    "image": "http://www.rittmanmead.com/blog/content/images/2017/06/1q1dx1-2.jpg",
    "keywords": "OBIEE12c, catalog validation, catalog, errors, command",
    "description": "The old 11g method for running catalog validation is no longer available in 12c.\nCheck out how to perform a full catalog validation in 12c.",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "http://www.rittmanmead.com/blog"
    }
}
    </script>

    <script type="text/javascript" src="/blog/shared/ghost-url.min.js?v=3df933d700"></script>
<script type="text/javascript">
ghost.init({
	clientId: "ghost-frontend",
	clientSecret: "1f95feaad444"
});
</script>
    <meta name="generator" content="Ghost 0.11" />
    <link rel="alternate" type="application/rss+xml" title="Rittman Mead" href="http://www.rittmanmead.com/blog/rss/" />
    <link rel="shortcut icon" href="/images/favicon.ico">
<link rel="stylesheet" type="text/css" href="/css/bootstrap.min.css">
<link rel="stylesheet" type="text/css" href="/css/plugins.css">
<link rel="stylesheet" type="text/css" href="/css/settings.css">
<link rel="stylesheet" type="text/css" href="/css/layers.css">
<link rel="stylesheet" type="text/css" href="/css/navigation.css">
<link rel="stylesheet" type="text/css" href="/css/style.css">
<link rel="stylesheet" type="text/css" href="/css/aqua.css">
<link rel="stylesheet" type="text/css" href="/css/icons.css">
<link rel="stylesheet" type="text/css" href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:400,900italic,900,700italic,600italic,600,400italic,700,300italic,300,200italic,200'>
<style>
.menu-button {
	display:none;
    }
</style>

<!-- HTML5 shim and Respond.js for IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
<![endif]-->
<script>
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-776858-2', 'auto');
        ga('send', 'pageview');
    </script>
<script type="text/javascript" src="/js/jquery.min.js"></script>
<script type="text/javascript" src="/js/bootstrap.min.js"></script>
<script type="text/javascript" src="/js/jquery.themepunch.tools.min.js?rev=5.0"></script>
<script type="text/javascript" src="/js/jquery.themepunch.revolution.min.js?rev=5.0"></script>
<script type="text/javascript" src="/js/revolution.extension.slideanims.min.js"></script>
<script type="text/javascript" src="/js/revolution.extension.layeranimation.min.js"></script>
<script type="text/javascript" src="/js/revolution.extension.navigation.min.js"></script>
<script type="text/javascript" src="/js/revolution.extension.carousel.min.js"></script>
<script type="text/javascript" src="/js/revolution.extension.video.min.js"></script>

  <div class="navbar navbar-default default header1" role="navigation">
    <div class="container">
        <div class="navbar-header">
            <div class="navbar-brand">
                <a href="http://www.rittmanmead.com/"><img src="/images/rmlogo_2color.svg" alt="rittmanmead" width="175" border="0" /></a>
            </div>
            <div class="nav-bars-wrapper">
                <div class="nav-bars-inner">
                    <div class="nav-bars" data-toggle="collapse" data-target=".navbar-collapse"><span></span></div>
                </div>
                <!-- /.nav-bars-inner -->
            </div>
            <!-- /.nav-bars-wrapper -->
        </div>
        <div class="navbar-collapse collapse">
            <ul class="nav navbar-nav">
                <li><a href="/services/">Services <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="/services/">Services</a></li>
                        <li><a href="/obiee-12c-upgrade/">OBIEE 12c Upgrade</a></li>
                        <li><a href="/obiee-health-check/">OBIEE Health Check</a></li>
                        <li><a href="/expert-service-desk/">Expert Service Desk</a></li>
                        <li><a href="/technologies/">Technologies</a></li>
                    </ul>
                </li>
                <li><a href="/training/">Training <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="/training/">Training</a></li>
                        <li><a href="/uk-training/">UK / Europe Training</a></li>
                        <li><a href="/us-training/">US Training</a></li>
                        <li><a href="/on-demand-training/">On Demand Training</a></li>
                    </ul>
                </li>
                <li><a href="/accelerators/">Products <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="/chitchat/">ChitChat</a></li>
                        <li><a href="/open-source-projects/">Open Source Projects</a></li>
                        <li><a href="/performance-analytics/">Performance Analytics</a></li>
                        <li><a href="/user-engagement/">User Engagement</a></li>
                        <li><a href="/unify/">Unify</a></li>
                    </ul>
                </li>
                <li><a href="/about-us/">About <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="/about-us/">About</a></li>
                        <li><a href="/contact/">Contact</a></li>
                        <li><a href="/resources/">Resources</a></li>
                        <li><a href="/partners/">Partners</a></li>
                        <li><a href="/our-books/">Our Books</a></li>
                    </ul>
                </li>
                <li><a href="http://www.rittmanmead.com/blog/">Blog</a>
                </li>
            </ul>
            <!-- /.navbar-nav -->
        </div>
        <!--/.nav-collapse -->
    </div>
    <!--/.container -->
</div>
<div class="offset"></div>
</head>
<body class="post-template tag-obiee12c tag-catalog-validation tag-catalog tag-errors tag-command nav-closed">

    <div class="nav">
    <h3 class="nav-title">Menu</h3>
    <a href="#" class="nav-close">
        <span class="hidden">Close</span>
    </a>
    <ul>
            <li class="nav-blog" role="presentation"><a href="http://www.rittmanmead.com/blog/">Blog</a></li>
    </ul>
        <a class="subscribe-button" href="http://www.rittmanmead.com/blog/subscribe/">Subscribe</a>
</div>
<span class="nav-cover"></span>


    <div class="site-wrapper">

        


<header class="main-header post-head " style="background-image: url('/images/blog/techInsight.svg')">
    <nav class="main-nav overlay clearfix">
        
            <a class="menu-button icon-menu" href="#"><span class="word">Menu</span></a>
    </nav>
</header>
<div class="row">
    <div class="col-md-10 col-md-offset-1">
        <div class="col-md-9 mainGhost">
            <main class="content" role="main">
                <article class="post tag-obiee12c tag-catalog-validation tag-catalog tag-errors tag-command">
                    <header class="post-header">
                        <h2 class="post-title" style="margin-top:4rem;">OBIEE 12c Catalog Validation: Command Line</h2>
                        <section class="post-meta">
                            <time class="post-date" datetime=" 2017-06-23 ">23 June 2017</time>  on <a href="/blog/tag/obiee12c/">OBIEE12c</a>, <a href="/blog/tag/catalog-validation/">catalog validation</a>, <a href="/blog/tag/catalog/">catalog</a>, <a href="/blog/tag/errors/">errors</a>, <a href="/blog/tag/command/">command</a>
                        </section>
                    </header>
                    <section class="post-content">
                        <p>I wrote a <a href="https://www.rittmanmead.com/blog/2016/11/performing-a-catalog-validation/">blog post</a> a while ago describing the catalog validation: an automated process performing a consistency check of the catalog and reporting or deleting the inconsistent artifacts. <br />
In the post I stated that catalog validation should be implemented regularly as part of the cleanup routines and provides precious additional information during the pre and post upgrade phases.</p>

<p>However some time later I noted Oracle's support <a href="https://support.oracle.com/epmos/faces/DocumentDisplay?&amp;id=2199938.1">Doc ID 2199938.1</a> stating that the startup procedure I detailed in the previous blog post is not supported in any OBI release since 12.2.1.1.0. You can imagine my reaction...</p>

<p><img src="/blog/content/images/2017/05/1q1dx1.jpg" alt="meme unsupported" /></p>

<p>The question then became: How do we run the catalog validation since the known procedure is unsupported? The answer is in catalog manager and the related command line call <code>runcat.sh</code> which, in the server installations (like the <a href="http://www.oracle.com/technetwork/middleware/bi-foundation/obiee-samples-167534.html">SampleApp v607p</a>), can be found under <code>$DOMAIN_HOME/bitools/bin</code>.</p>

<h1 id="howdoesitwork">How Does it Work?</h1>

<p>As for most of command line tools, when you don't have a clue on how it works, the best approach is to run with the <code>-help</code> option which provides the list of parameters to pass.</p>

<pre><code>Catalog Manager understands commands in the following areas:

Development To Production  
createFolder        Creates folder in the catalog  
delete            Deletes the given path from the catalog  
maintenanceMode        Puts the catalog into or out of Maintenance Mode (aka ReadOnly)  
...

Multi-Tenancy  
provisionTenant        Provisions tenants into a web catalog  
...

Patch Management  
tag            Tags all XML documents in a catalog with a unique id and common version string  
diff            Compares two catalogs  
inject            Injects a single item to a diff file  
...

Subject Area Management  
clearQueryCache        Clears the query cache  
</code></pre>

<p>Unfortunately none of the options in the list seems to be relevant for catalog validation, but with a close look at the recently updated <a href="https://support.oracle.com/epmos/faces/DocumentDisplay?&amp;id=2199938.1">Doc ID 2199938.1</a> I could find the parameter to pass: <code>validate</code>. <br />
The full command then looks like  </p>

<pre><code>./runcat.sh -cmd validate
</code></pre>

<p>In my <a href="https://www.rittmanmead.com/blog/2016/11/performing-a-catalog-validation/">previous blog</a> I mentioned different types of validation. What type of validation is the default command going to implement? How can I change the behaviour? Again the <code>-help</code> option provides the list of instructions.</p>

<pre><code># Command : -cmd validate -help 

validate        Validates the catalog

Description  
Validates the catalog

For more information, please see the Oracle Business Intelligence Suite  
Enterprise Edition's Presentation Services Administration Guide.

Syntax  
runcat.cmd/runcat.sh -cmd validate  
    [ -items (None | Report | Clean) [ -links (None | Report | Clean) ] [-folder &lt;path{:path}&gt;] [-folderFromFile &lt;path of inclusion list file&gt;] ] 
    [ -accounts (None | Report | Clean) [ -homes (None | Report | Clean) ] ] 
    -offline &lt;path of catalog&gt; 

Basic Arguments  
None

Optional Arguments  
-items (None | Report | Clean)        Default is 'Report' 
-links (None | Report | Clean)        Default is 'Clean'. Also, '-items' cannot be 'None'. 
-accounts (None | Report | Clean)        Default is 'Clean' 
-homes (None | Report | Clean)        Default is 'Report'. Also, '-accounts' cannot be 'None'. 
-folder &lt;path{:path}&gt;            Which folders in the catalog to validate
-folderFromFile &lt;path of inclusion list file&gt;            File containing folders in the catalog to validate

Common Arguments  
-offline &lt;path of catalog&gt;

-folderFromFile &lt;folder from file&gt;        ----- Sample Folder From File ------
                        /shared/groups/misc
                        /shared/groups/_filters
                        ------------------------------------

Example  
runcat.cmd/runcat.sh -cmd validate -offline c:\oraclebi\data\web\catalog\paint  
</code></pre>

<p>Few bits to notice:</p>

<ul>
<li><strong>-offline</strong>: the catalog validation needs to happen offline. Either with services down or on a copy of the live catalog. Running catalog validation on a online catalog is dangerous especially with <em>"Clean"</em> options since could delete content in use.</li>
<li><strong>-folder</strong>: the catalog validation can be run only for a subset of the catalog</li>
<li><strong>None | Report | Clean</strong>: each validation can be skipped (None), logged (Report) or solved via removal of the inconsistent object (Clean)</li>
<li><strong>Also, '-accounts' cannot be 'None'.</strong>: some validations are a prerequisite for others to happen</li>
<li><strong>Default is 'Clean'</strong>: some validations have a <em>"Clean"</em> as default value, meaning that will solve the issue by removing the inconsistent object, this may be inappropriate in some cases.</li>
</ul>

<p>As written before, the initial catalog validation should be done with all options set on <em>Report</em> since this will give a log file of all inconsistencies without deleting pieces of the catalog that could still be valuable. In order to do so the command to execute is:</p>

<pre><code>./runcat.sh -cmd validate -items Report -links Report -accounts Report -homes Report -offline &lt;path_to_catalog&gt; &gt; cat_validation.log
</code></pre>

<p><code>runcat.sh</code> output is displayed direcly in the console, I'm redirecting it to a file called <code>cat_validation.log</code> for further analysis.</p>

<p>If, after the initial run with all options to <em>Report</em> you want the catalog validation utility to "fix" the inconsistent objects, just change the desired options to <em>Clean</em>. Please make sure to take a backup of the catalog before since the automatic fix is done by removing the related objects. Moreover ensure that catalog validation is working on a <strong>offline catalog</strong>. The command itself can work on top on a online catalog but is never a good idea checking a catalog that could potentially be changed while the tool is running.</p>

<h1 id="theoutput">The output</h1>

<p>Let's see few examples of how Catalog Validation spots inconsistent objects. For the purpose of this test I'll work with <a href="http://www.oracle.com/technetwork/middleware/bi-foundation/obiee-samples-167534.html">Oracle's Sampleapp</a>.</p>

<h2 id="abandonedandinaccessiblehomes">Abandoned and inaccessible homes</h2>

<p>Running the validation against the Sampleapp catalog provides some "interesting" results: some homes are declared "abandoned": this could be due to the related user not existing anymore in weblogic console, but that's not the case  </p>

<pre><code>E10    saw.security.validate.homes Abandoned home /users/weblogic  
</code></pre>

<p>Looking deeper in the logs we can see that the same user folders are flagged as</p>

<pre><code>User facing object '/users/weblogic' has no user permissions and is inaccessible  
</code></pre>

<p>Logging in with the user <code>weblogic</code> doesn't allow me to check the "My Folders" in the catalog. When switching to <em>"Admin View"</em> and trying to open "My Folder" I get the following error</p>

<p><img src="/blog/content/images/2017/06/My-Folder-Error.png" alt="Error My Folder" /></p>

<p>As written in the logs looks like the user folder has permission problems. How can we solve this? One option is to use again the <code>runcat.sh</code> command with the <code>forgetAccounts</code> option to remove the inconsistent homes. However this solution deletes all the content related to the user that was stored under the "My Folders". </p>

<p>In order to keep the content we need to overwrite the folder's permission with an administrator account. Unfortunately, when right-clicking on the folder, the "Permission" option is not available.</p>

<p><img src="/blog/content/images/2017/06/Properties-1.png" alt="Permissions" /></p>

<p>As a workaround I found that clicking on <code>Properties</code> and then on <code>Set Ownership of this item and all subitems</code> allows you to grant full access to the administrator which is then able to reset the proper user the relevant access privilege.</p>

<p><img src="/blog/content/images/2017/06/change-ownership.png" alt="Change ownership" /></p>

<p>Once the workaround is implemented the users is able to check his "My Folder" content, however the the errors are still present in catalog validation. The solution is storing the relevant artifacts in another part of the catalog, run <code>runcat.sh</code> with <code>forgetAccounts</code> option and then reimport the objects if needed.</p>

<h2 id="inconsistentobjects">Inconsistent Objects</h2>

<p>The main two reasons generating inconsistent objects are:</p>

<ul>
<li><strong>Invalid XML</strong>: The object (analysis or dashboard) XML code is not valid. This can be caused by errors during the write to disk or problems during migrations.</li>
<li><strong>Broken Links</strong>: analysis contained in a dashboard or linked from other analysis have been renamed or deleted.</li>
</ul>

<p>Let's see how catalog validation shows the errors.</p>

<h3 id="invalidxml">Invalid XML</h3>

<p>To test this case I created a simple analysis with two columns and then went to the <em>Advanced</em> tab and deliberately removed an <code>&gt;</code> to make the XML invalid.</p>

<p><img src="/blog/content/images/2017/06/Screwed-XML-1.png" alt="Invalid XML" /></p>

<p>When trying to applying the change I got the following error which denied me the possibility to save.</p>

<p><img src="/blog/content/images/2017/06/Error-XML.png" alt="Error XML" /></p>

<p>Since I really wanted to ruin my analysis I went directly to the file system under <code>$BI_HOME/bidata/service_instances/ssi/metadata/content/catalog/root/shared/$REQUEST_PATH</code> and changed the XML directly there.</p>

<p>After than I run the catalog validation with only the flag <code>items</code> equal to  <code>Report</code> and the rest set to <code>None</code> since I'm looking only at invalid XMLs. <br />
The result as expected is:</p>

<pre><code>Message: Unterminated start tag, 'saw:column', Entity publicId: /app/oracle/biee/user_projects/domains/bi/bidata/service_instances/ssi/metadata/content/catalog/root/shared/rm+demo/notworkinanalysis, Entity systemId: , Line number: 9, Column number: 13  
</code></pre>

<p>Which tells me that my analysis <code>notworkinganalysis</code> is invalid with an unterminated start tag, exactly the error I was expecting. Now I have two choices: either fixing the analysis XML manually or rerunning the catalog validation with option <code>Clean</code> which will delete the analysis since it's invalid. As said before there is no automated fix.</p>

<p>I wanted to do a further example on this, instead of removing the <code>&gt;</code>, i removed a quotation mark <code>"</code> to make the analysis invalid</p>

<p><img src="/blog/content/images/2017/06/Screwed-Column.png" alt="Quotation Mark" /></p>

<p>After clicking to <em>Apply</em> OBIEE already tells me that there is something wrong in the analysis. But since it allows me to save and since I feel masochist I saved the analysis.</p>

<p><img src="/blog/content/images/2017/06/Error-before-Saving.png" alt="Error" /></p>

<p>But... when running the catalog validation as before I end up seeing <strong>0 errors</strong> related to my <code>notworkinganalysis</code>. </p>

<p><img src="/blog/content/images/2017/06/1rb66j.jpg" alt="How is it possible" /></p>

<p>The answer to Jackie Chan question is that I got 0 errors since in this second case the <strong>XML is still valid</strong>. Removing a <code>"</code> doesn't make the XML syntax invalid! In order to find and solve that error we would need to use Oracle's <a href="http://www.oracle.com/technetwork/middleware/bi/downloads/bi-bvt-download-3587672.html">Baseline Validation Tool</a>. </p>

<h3 id="brokenlinks">Broken Links</h3>

<p>To test the broken links case I created the following scenario:</p>

<ul>
<li>Analysis <code>SourceAnalysis</code> which has navigation action to <code>TargetAnalysis</code></li>
</ul>

<p><img src="/blog/content/images/2017/06/Interaction.png" alt="Interaction" /></p>

<ul>
<li>Dashboard <code>TestDashboard</code> which contains the <code>TargetAnalysis</code> object.</li>
</ul>

<p>In order to break things I then deleted the <code>TargetAnalysis</code>.</p>

<p><img src="/blog/content/images/2017/06/Delete.png" alt="Del" /></p>

<p>Running catalog validation with the option <code>links</code> to <code>Report</code>. As expected I get a line</p>

<pre><code>N1    saw.catalog.impl.scour.validateDeadLink Referenced path /shared/RM Demo/TargetAnalysis in file /shared/RM Demo/_portal/TestDashboard/page 1 is inaccessible.  
</code></pre>

<p>But I don't get anything on the <code>SourceRequest</code> object, for which navigation is failing.</p>

<p><img src="/blog/content/images/2017/06/Error.png" alt="Error" /></p>

<p>But if instead of an action link I use <code>TargetAnalysis</code> to filter the results of <code>SourceAnalysis</code></p>

<p><img src="/blog/content/images/2017/06/Filter.png" alt="Filter" /></p>

<p>And then delete <code>TargetAnalysis</code>, I get the expected error:</p>

<pre><code>N1    saw.catalog.impl.scour.validateDeadLink Referenced path /shared/RM Demo/TargetAnalysis in file /shared/RM Demo/SourceAnalysis is inaccessible
</code></pre>

<p>Summarizing the <strong>broken link</strong> validation reports if missing objects are included in the main definition of other objects (as filters or as parts of dashboards) but doesn't seem to report if the missing object is only linked via an action.</p>

<h1 id="conclusion">Conclusion</h1>

<p>My experiments show that catalog validation finds some errors like invalid homes, XML files and broken links which otherwise users would hit at the run-time and that won't make them happy. But there are still some errors which it doesn't log like analysis with wrong column syntax, luckily for most of the cases other tools like the Baseline Validation can spot them easily so use all you have, use as frequently as possible and if you want  more details about how it works and how it can be included in the automatic checks for code promotions don't hesitate to <a href="mailto:info+ftcv2@rittmanmead.com">contact us</a>!</p>
                    </section>
                    <div id="disqus_thread"></div>
                        <footer class="post-footer">
                             
                            <section class="gh-subscribe">
                                <h3 class="gh-subscribe-title">Subscribe to Rittman Mead</h3>
                                <p>Get the latest posts delivered right to your inbox.</p>
                                <form method="post" action="/blog/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="Your email address" />
    </div>
    <button class="" type="submit">Subscribe</button>
    <script type="text/javascript">(function(g,h,o,s,t){h[o]('.location')[s]=h[o]('.location')[s] || g.location.href;h[o]('.referrer')[s]=h[o]('.referrer')[s] || h.referrer;})(window,document,'querySelector','value');</script>
</form>


                                <span class="gh-subscribe-rss">or subscribe <a href="http://cloud.feedly.com/#subscription/feed/http://www.rittmanmead.com/blog/rss/">via RSS</a> with Feedly!</span>
                            </section>
                        </footer>
                </article>
            </main>
        </div>
        <div class="col-md-3 sideGhost">
            <aside class="blog-sidebar">
    <section class="author">
        <section class="author">
             
                <figure class="author-image">
                    <a class="img" href="/blog/author/francesco-tisiot/" style="background-image: url(/blog/content/images/2016/10/Ftisiot.jpg)"><span class="hidden">Francesco Tisiot's Picture</span></a>
                </figure>
                <section class="author">
                    <h3><a href="/blog/author/francesco-tisiot/">Francesco Tisiot</a></h3> 
                    <p style="font-size:16px !important;">OBI Tech Lead EMEA and Principal Consultant at Rittman Mead, OBIEE enthusiast, Speaker, Blogger, Trainer.</p>
                    <div class="author-meta">
                        <span class="author-location icon-location">Verona, IT</span> 
                    </div>
                </section>
       </section>
    </section>
    <section class="share">
        <h3>Share this Post</h3>
        <a class="icon-twitter" style="font-size:25px !important;color:#808080;" href="https://twitter.com/intent/tweet?text=OBIEE%2012c%20Catalog%20Validation%3A%20Command%20Line&amp;url=http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/" onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;">
            <span class="hidden">Twitter</span>
        </a>
        <a class="icon-facebook" style="font-size:25px !important;color:#808080;" href="https://www.facebook.com/sharer/sharer.php?u=http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/" onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;">
            <span class="hidden">Facebook</span>
        </a>
        <a class="icon-google-plus" style="font-size:25px !important;color:#808080;" href="https://plus.google.com/share?url=http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/" onclick="window.open(this.href, 'google-plus-share', 'width=490,height=530');return false;">
            <span class="hidden">Google+</span>
        </a>
    </section>
    <section class="blogpost-headers">
        <div class="button btn" style="width:100%; color:#fff; font-size:16px;">
            <a style="color:#fff;" href="/blog/tag/technical" style="font-size:16px;">Technical Insights</a>
        </div>
        <div class="button btn" style="width:100%; color:#fff; font-size:16px;">
            <a style="color:#fff;" href="/blog/tag/business-insights" style="font-size:16px;">Business Insights</a>
        </div>
        <div class="button btn" style="width:100%; color:#fff; font-size:16px;">
            <a style="color:#fff;" href="/blog/tag/rittman-mead-life" style="font-size:16px;">Rittman Mead Life</a>
        </div>
    </section>
	<section class="search-field">
        <div class="bm20">
            <h3>Search the Blog</h3>
        </div>
        <script>
              (function() {
                var cx = '011968080232057045375:lx7booyq-8q';
                var gcse = document.createElement('script');
                gcse.type = 'text/javascript';
                gcse.async = true;
                gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
                var s = document.getElementsByTagName('script')[0];
                s.parentNode.insertBefore(gcse, s);
              })();
        </script>
        <gcse:search></gcse:search>
    </section>
    <section>
        <div class="bm20">
            <h3>Sign Up for Our Newsletter</h3>
        </div>
        <div id="mc_embed_signup">
            <form action="//rittmanmead.us10.list-manage.com/subscribe/post?u=e4ade60a8963f96a9c97d0bfc&amp;id=4a160dccbf" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
                <div id="mc_embed_signup_scroll">

                    <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
                    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
                    <div style="position: absolute; left: -5000px;" aria-hidden="true">
                        <input type="text" name="b_e4ade60a8963f96a9c97d0bfc_4a160dccbf" tabindex="-1" value="">
                    </div>
                    <div class="clear">
                        <input style="width:100%;font-size:16px;" type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button btn">
                    </div>
                </div>
            </form>
        </div>
    </section>
    <section class="recent-posts">
        <h3>Recent Posts</h3>
        <ul class="sidebarLink">
            <li style="font-size:16px;"><a href="/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/">OBIEE 12c Catalog Validation: Command Line</a></li>
            <li style="font-size:16px;"><a href="/blog/2017/06/getting-smarter-in-renting-with-tableau-10/">Getting Smarter in Renting with Tableau 10</a></li>
            <li style="font-size:16px;"><a href="/blog/2017/06/rittman-mead-at-kscope-2017/">Rittman Mead at Kscope 2017</a></li>
            <li style="font-size:16px;"><a href="/blog/2017/06/unify-could-it-be-easier/">Unify: Could it be any easier?</a></li>
            <li style="font-size:16px;"><a href="/blog/2017/06/unify-an-insight-into-the-product/">Unify - An Insight Into the Product</a></li>
        </ul>
    </section>
</aside>
        </div>
    </div>
</div>
<aside class="read-next">
    <a class="read-next-story prev no-cover" href="/blog/2017/06/getting-smarter-in-renting-with-tableau-10/">
        <section class="post">
            <h2>Getting Smarter in Renting with Tableau 10</h2>
            <p>Preface Not a long time ago a friend of mine spent a significant amount of time trying to find&hellip;</p>
        </section>
    </a>
</aside>
<script>
/**
* RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
* LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
*/

var disqus_config = function () {
this.page.url = 'http://www.rittmanmead.com/blog/2017/06/obiee-catalog-validation-running-it-from-command-line/';
this.page.identifier = 'ghost-20650';
};

(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');

s.src = '//rittmanmead.disqus.com/embed.js';

s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>


       <!-- <footer class="site-footer clearfix">
            <section class="copyright"><a href="http://www.rittmanmead.com/blog">Rittman Mead</a> &copy; 2017</section>
            <section class="poweredby">Proudly published with <a href="https://ghost.org">Ghost</a></section>
        </footer>-->
	<footer class="footer inverse-wrapper">
    <div class="container inner2">
        <div class="row">
            <div class="col-sm-4">
                <div class="widget">
                    <h3 class="widget-title">About Us</h3>
                    <p>Hundreds of organizations, from Fortune 500 companies to Ivy Leagues to startups, trust Rittman Mead as a source of knowledge about business intelligence, data, and analytics. What could your business do with the faster, more insightful analytics?</p>
                    <ul class="social naked">
                        <li>
                            <a href="http://www.rittmanmead.com/feed/">
                                <i class="icon-s-rss"></i></a>
                        </li>
                        <li>
                            <a href="http://twitter.com/rittmanmead">
                                <i class="icon-s-twitter"></i></a>
                        </li>
                        <li>
                            <a href="https://www.facebook.com/rittmanmead/">
                                <i class="icon-s-facebook"></i></a>
                        </li>
                        <li>
                            <a href="http://www.linkedin.com/company/rittman-mead">
                                <i class="icon-s-linkedin"></i></a>
                        </li>
                    </ul>
                </div>
            </div>
            <!-- /column -->
            <div class="col-sm-8">
                <div class="col-md-6">
                    <h3 class="widget-title">Get in Touch</h3>
                    <p> <strong>Rittman Mead Consulting Ltd.</strong>
                        <br> Suite B, First Floor,
                        <br> Moore House, 11-13 Black Lion Street,
                        <br> Brighton, BN1 1ND, United Kingdom
                        <br>
                        <br> <abbr title="Phone">P:</abbr> +44 (0) 1273 911 268
                        <br> <abbr title="Email">E:</abbr> info@rittmanmead.com
                        <br>
                    </p>
                </div>
                <div class="col-md-6">
                    <h4 class="widget-title">&nbsp;</h4>
                    <p><strong>Rittman Mead America Inc.</strong>
                        <br> 5280 Avalon Boulevard
                        <br> Alpharetta, GA 30009
                        <br>
                        <br> <abbr title="Phone">P:</abbr> (888) 631-1410
                        <br> <abbr title="Email">E:</abbr> info@rittmanmead.com
                        <br>
                    </p>
                </div>
            </div>
            <!-- /column -->
        </div>
        <!-- /.row -->
    </div>
    <!-- .container -->
    <div class="sub-footer">
        <div class="container inner3">
            <p class="text-center">© 2010 - 2016 Rittman Mead. All rights reserved.</p>
            <p class="text-center"><a href="/privacy-policy/">Privacy Policy</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/cookies/">Manage Your Cookie Settings</a></p>
        </div>
        <!-- .container -->
    </div>
    <!-- .sub-footer -->
</footer>
<script type="text/javascript" src="/js/plugins.js"></script>
<script type="text/javascript" src="/js/scripts.js"></script>
<script defer>
    if (window.update_cookieconsent_options != null) {
    window.update_cookieconsent_options({
        "learnMore": ' Learn More'
        , "message": "This site creates and uses cookies. Click here to"
        , "link": 'http://www.rittmanmead.com/cookies/'
        , "theme": "/css/cookiestyle.css"
        , "container": ".full-layout"
    });

    } else {
    window.cookieconsent_options = {
        "learnMore": ' Learn More'
        , "message": "This site creates and uses cookies. Click here to"
        , "link": 'http://www.rittmanmead.com/cookies/'
        , "theme": "/css/cookiestyle.css"
        , "container": ".full-layout"
    };
    }
</script>
<!-- newsletter code -->
<div id="subscriber-signup" class="newsFooter">
    <div class="row">
                <div class="col-md-10">
                    <h3 style="color:#304049;font-size:2em !important;">Subscribe to Our<br>Monthly Newsletter!</h3>
                </div>
                <div class="col-md-2">
                    <button id="exit-button" style="padding-left:0 !important;">
                        <i class="icon-cancel-circle" style="font-size:20px;color:#1c8ca3;"></i>
                        <div class="divide10"></div>
                    </button>
                </div>
            </div>
    <form action="//rittmanmead.us10.list-manage.com/subscribe/post?u=e4ade60a8963f96a9c97d0bfc&amp;id=4a160dccbf" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
        <div id="mc_embed_signup_scroll">
            <div class="indicates-required bm10"><span class="asterisk">*</span> indicates required</div>
            <div class="mc-field-group">
                <label for="mce-EMAIL" class="newsFormText">Email Address <span class="asterisk">*</span> </label>
                <input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" style="background:#ffffff;"> </div>
            <div class="mc-field-group">
                <label for="mce-FNAME" class="newsFormText">First Name </label>
                <input type="text" value="" name="FNAME" class="" id="mce-FNAME"style="background:#ffffff;"> </div>
            <div class="mc-field-group">
                <label for="mce-LNAME" class="newsFormText">Last Name </label>
                <input type="text" value="" name="LNAME" class="" id="mce-LNAME"style="background:#ffffff;"> </div>
            <div id="mce-responses" class="clear">
                <div class="response" id="mce-error-response" style="display:none"></div>
                <div class="response" id="mce-success-response" style="display:none"></div>
            </div>
            <div style="position: absolute; left: -5000px;" aria-hidden="true">
                <input type="text" name="b_e4ade60a8963f96a9c97d0bfc_4a160dccbf" tabindex="-1" value="">
            </div>
            <div class="divide20"></div>
            <div class="clear">
                <input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button btn">
            </div>
        </div>
    </form>
    <button id="ignore-subscribe" style="padding-left:0 !important;float:right;"><span style="color:#1c8ca3;">Don't Show This Again</span></button>
</div>
<script defer>
    var cookieName = "rm-subscribe-respond"
    jQuery(document).ready(function () {
        //popup window after 3 seconds
        if (screen.width >= 480) {
                if (document.cookie.indexOf(cookieName) == -1) {
		    jQuery("#subscriber-signup").addClass("subscriber-signup-anim");
                }
        }
        //button to close window w/ subscribe and ignore
        jQuery("#mc-embedded-subscribe").click(function () {
            //submit form
            //set cookie
            document.cookie = cookieName + "=true; expires=Wed, 1 Jan 2030 00:00:01 UTC; path=/"
	    jQuery("#subscriber-signup").removeClass("subscriber-signup-anim");
        });
        jQuery("#ignore-subscribe").click(function () {
            //close window and set cookie
            document.cookie = cookieName + "=true; expires=Wed, 1 Jan 2030 00:00:01 UTC; path=/"
	    jQuery("#subscriber-signup").removeClass("subscriber-signup-anim");
        });
        jQuery("#exit-button").click(function () {
	    jQuery("#subscriber-signup").removeClass("subscriber-signup-anim");
        });
    });
</script>
<!-- Heap Tracking Code -->
<script type="text/javascript">
    window.heap=window.heap||[],heap.load=function(e,t){window.heap.appid=e,window.heap.config=t=t||{};var r=t.forceSSL||"https:"===document.location.protocol,a=document.createElement("script");a.type="text/javascript",a.async=!0,a.src=(r?"https:":"http:")+"//cdn.heapanalytics.com/js/heap-"+e+".js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(a,n);for(var o=function(e){return function(){heap.push([e].concat(Array.prototype.slice.call(arguments,0)))}},p=["addEventProperties","addUserProperties","clearEventProperties","identify","removeEventProperty","setEventProperties","track","unsetEventProperty"],c=0;c<p.length;c++)heap[p[c]]=o(p[c])};
      heap.load("3641204034");
</script>
<!-- End Head Tracking Code -->

    </div>

    <script type="text/javascript" src="https://code.jquery.com/jquery-1.12.0.min.js"></script>

    <script type="text/javascript" src="/blog/assets/js/jquery.fitvids.js?v=3df933d700"></script>
    <script type="text/javascript" src="/blog/assets/js/index.js?v=3df933d700"></script>

</body>
</html>
