<!DOCTYPE html>
<html>
<head>
    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />
    <meta name="google-site-verification" content="9f4nRUzJk0UTY2k2U2lN9MiIaI-HReD4LJ1Wq0vgpow" />
    <title>Making our way into Dremio</title>
    <meta name="description" content="" />

    <meta name="HandheldFriendly" content="True" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="shortcut icon" href="/blog/favicon.ico">

    <link rel="stylesheet" type="text/css" href="/blog/assets/css/screen.css?v=b1253d6f60" />
    <link rel="stylesheet" type="text/css" href="//fonts.googleapis.com/css?family=Merriweather:300,700,700italic,300italic|Open+Sans:700,400" />

    <link rel="canonical" href="https://www.rittmanmead.com/blog/2018/07/untitled/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    <link rel="amphtml" href="https://www.rittmanmead.com/blog/2018/07/untitled/amp/" />
    
    <meta property="og:site_name" content="Rittman Mead" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="Making our way into Dremio" />
    <meta property="og:description" content="In an analytics system, we typically have an Operational Data Store (ODS) or staging layer; a performance layer or some data marts; and on top, there would be an exploration or reporting tool such as Tableau or Oracle&#x27;s OBIEE. This architecture can lead to latency in decision making, creating a" />
    <meta property="og:url" content="https://www.rittmanmead.com/blog/2018/07/untitled/" />
    <meta property="article:published_time" content="2018-07-25T09:07:32.000Z" />
    <meta property="article:modified_time" content="2018-07-25T09:07:32.000Z" />
    <meta property="article:publisher" content="https://www.facebook.com/rittmanmead" />
    <meta name="twitter:card" content="summary" />
    <meta name="twitter:title" content="Making our way into Dremio" />
    <meta name="twitter:description" content="In an analytics system, we typically have an Operational Data Store (ODS) or staging layer; a performance layer or some data marts; and on top, there would be an exploration or reporting tool such as Tableau or Oracle&#x27;s OBIEE. This architecture can lead to latency in decision making, creating a" />
    <meta name="twitter:url" content="https://www.rittmanmead.com/blog/2018/07/untitled/" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Nélio Guimarães" />
    <meta name="twitter:site" content="@rittmanmead" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "Rittman Mead",
        "logo": "https://www.rittmanmead.com/blog/ghost/img/ghosticon.jpg"
    },
    "author": {
        "@type": "Person",
        "name": "Nélio Guimarães",
        "url": "https://www.rittmanmead.com/blog/author/nelio-guimaraes/",
        "sameAs": []
    },
    "headline": "Making our way into Dremio",
    "url": "https://www.rittmanmead.com/blog/2018/07/untitled/",
    "datePublished": "2018-07-25T09:07:32.000Z",
    "dateModified": "2018-07-25T09:07:32.000Z",
    "description": "In an analytics system, we typically have an Operational Data Store (ODS) or staging layer; a performance layer or some data marts; and on top, there would be an exploration or reporting tool such as Tableau or Oracle&#x27;s OBIEE. This architecture can lead to latency in decision making, creating a",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://www.rittmanmead.com/blog"
    }
}
    </script>

    <script type="text/javascript" src="/blog/shared/ghost-url.min.js?v=b1253d6f60"></script>
<script type="text/javascript">
ghost.init({
	clientId: "ghost-frontend",
	clientSecret: "1f95feaad444"
});
</script>
    <meta name="generator" content="Ghost 0.11" />
    <link rel="alternate" type="application/rss+xml" title="Rittman Mead" href="https://www.rittmanmead.com/blog/rss/" />
    <link rel="shortcut icon" href="/images/favicon.ico">
<link rel="stylesheet" type="text/css" href="/css/bootstrap.min.css">
<link rel="stylesheet" type="text/css" href="/css/plugins.css">
<link rel="stylesheet" type="text/css" href="/css/settings.css">
<link rel="stylesheet" type="text/css" href="/css/layers.css">
<link rel="stylesheet" type="text/css" href="/css/navigation.css">
<link rel="stylesheet" type="text/css" href="/css/style.css">
<link rel="stylesheet" type="text/css" href="/css/custom.css">
<link rel="stylesheet" type="text/css" href="/css/aqua.css">
<link rel="stylesheet" type="text/css" href="/css/icons.css">
<link rel="stylesheet" type="text/css" href='https://fonts.googleapis.com/css?family=Source+Sans+Pro:400,900italic,900,700italic,600italic,600,400italic,700,300italic,300,200italic,200'>
<style>
.menu-button {
	display:none;
    }
</style>

<!-- HTML5 shim and Respond.js for IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
<![endif]-->
<script>
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-776858-2', 'auto');
        ga('send', 'pageview');
    </script>
<script type="text/javascript" src="/js/jquery.min.js"></script>
<script type="text/javascript" src="/js/bootstrap.min.js"></script>
<script type="text/javascript" src="/js/jquery.themepunch.tools.min.js?rev=5.0"></script>
<script type="text/javascript" src="/js/jquery.themepunch.revolution.min.js?rev=5.0"></script>
<script type="text/javascript" src="/js/revolution.extension.slideanims.min.js"></script>
<script type="text/javascript" src="/js/revolution.extension.layeranimation.min.js"></script>
<script type="text/javascript" src="/js/revolution.extension.navigation.min.js"></script>
<script type="text/javascript" src="/js/revolution.extension.carousel.min.js"></script>
<script type="text/javascript" src="/js/revolution.extension.video.min.js"></script>

  <div class="navbar navbar-default default header1" role="navigation">
    <div class="container">
        <div class="navbar-header">
            <div class="navbar-brand">
                <a href="http://www.rittmanmead.com/"><img src="/images/rmlogo_2color.svg" alt="rittmanmead" width="175" border="0" /></a>
            </div>
            <div class="nav-bars-wrapper">
                <div class="nav-bars-inner">
                    <div class="nav-bars" data-toggle="collapse" data-target=".navbar-collapse"><span></span></div>
                </div>
                <!-- /.nav-bars-inner -->
            </div>
            <!-- /.nav-bars-wrapper -->
        </div>
        <div class="navbar-collapse collapse">
            <ul class="nav navbar-nav">
                <li><a href="/services/">Services <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="/services/">Services</a></li>
                        <li><a href="/obiee-12c-upgrade/">OBIEE 12c Upgrade</a></li>
                        <li><a href="/obiee-health-check/">OBIEE Health Check</a></li>
                        <li><a href="/expert-service-desk/">Expert Service Desk</a></li>
                        <li><a href="/technologies/">Technologies</a></li>
                    </ul>
                </li>
                <li><a href="/training/">Training <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="/training/">Training</a></li>
                        <li><a href="/uk-training/">UK / Europe Training</a></li>
                        <li><a href="/us-training/">US Training</a></li>
                        <li><a href="/on-demand-training/">On Demand Training</a></li>
                    </ul>
                </li>
                <li><a href="/accelerators/">Products <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="/unify/">Unify</a></li>
                        <li><a href="/ignite-bi/">Ignite BI</a></li>
                        <li><a href="/performance-analytics/">Performance Analytics</a></li>
                        <li><a href="/chitchat/">ChitChat</a></li>
                        <li><a href="/user-engagement/">User Engagement</a></li>
                        <li><a href="/open-source-projects/">Open Source Projects</a></li>
                    </ul>
                </li>
                <li><a href="/about-us/">About <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                        <li><a href="/about-us/">About</a></li>
                        <li><a href="/contact/">Contact</a></li>
                        <li><a href="/resources/">Resources</a></li>
                        <li><a href="/partners/">Partners</a></li>
                        <li><a href="/our-books/">Our Books</a></li>
                    </ul>
                </li>
                <li><a href="http://www.rittmanmead.com/blog/">Blog</a>
                </li>
            </ul>
            <!-- /.navbar-nav -->
        </div>
        <!--/.nav-collapse -->
    </div>
    <!--/.container -->
</div>
<div class="offset"></div>
</head>
<body class="post-template nav-closed">

    

    <div class="site-wrapper">

        

<style>
    .post-meta a {
        color:#fff !important;
    }
</style>
<header class="main-header post-head " style="background-image: url('/images/blog/techInsight.svg')">
    <nav class="main-nav  clearfix">
        
    </nav>
    <header class="post-header thin text-left">
        <h1 class="newHeaderTitle" style="margin-top:4rem;">Making our way into Dremio</h1>
        <section class="post-meta" style="font-size:20px !important;color:#fff !important;">
            <time class="post-date" style="font-size:20px;" datetime=" 2018-07-25 ">25 July 2018</time> 
        </section>
    </header>
</header>
<div class="row">
    <div class="col-md-10 col-md-offset-1">
        <div class="col-md-9 mainGhost">
            <main class="content" role="main">
                <article class="post">

                    <section class="post-content">
                        <p>In an analytics system, we typically have an Operational Data Store (ODS) or staging layer; a performance layer or some data marts; and on top, there would be an exploration or reporting tool such as Tableau or Oracle's OBIEE. This architecture can lead to latency in decision making, creating a gap between analysis and action. Data preparation tools like Dremio can address this.</p>

<p><img src="/blog/content/images/2018/07/GUID-65DF513D-DFC8-4046-8AA5-24292AF5942F-default-1.png" alt="" /></p>

<p>Dremio is a Data-as-a-Service platform allowing users to quickly query data, directly from the source or in any layer, regardless of its size or structure. The product makes use of Apache Arrow, allowing it to virtualise data through an in-memory layer, creating what is called a Data Reflection.</p>

<p>The intent of this post is an introduction to Dremio; it provides a step by step guide on how to query data from Amazon's S3 platform.</p>

<p>I wrote this post using my MacBook Pro, Dremio is supported on MacOS. To install it, I needed to make some configuration changes due to the Java version. The latest version of Dremio uses Java 1.8. If you have a more recent Java version installed, you’ll need to make some adjustments to the Dremio configuration files. </p>

<p>Lets start downloading Dremio and installing it. Dremio can be found for multiple platforms and we can download it from <a href="https://www.dremio.com/download/">here</a>.</p>

<p>Dremio uses Java 1.8, so if you have an early version please make sure you install java 1.8 and edit  <code>/Applications/Dremio.app/Contents/Java/dremio/conf/dremio-env</code> to point to the directory where java 1.8 home is located.</p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-04-at-09.17.15.png" alt="" /></p>

<p>After that you should be able to start Dremio as any other MacOs application and access <code>http://localhost:9047</code></p>

<p><img alt="Image Description" src="/blog/content/images/2018/07/Screen-Shot-2018-07-09-at-11.55.25.png" style="width: 360px; height:280px"></p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-09-at-10.35.55.png" alt="" /></p>

<h3 id="configurings3source">Configuring S3 Source</h3>

<p>Dremio can connect to relational databases (both commercial and open source), NoSQL, Hadoop, cloud storage, ElasticSearch, among others. However the scope of this post is to use a well known NoSQL storage S3 bucket (more details can be found <a href="https://docs.aws.amazon.com/AmazonS3/latest/dev/UsingBucket.html">here</a>) and show the query capabilities of Dremio against unstructured data.</p>

<p>For this demo we're using Garmin CSV activity data that can be easily <a href="https://connect.garmin.com/">downloaded</a> from Garmin activity page. </p>

<p>Here and example of a CSV Garmin activity. If you don't have a Garmin account you can always replicate the data above.</p>

<pre><code>act,runner,Split,Time,Moving Time,Distance,Elevation Gain,Elev Loss,Avg Pace,Avg Moving Paces,Best Pace,Avg Run Cadence,Max Run Cadence,Avg Stride Length,Avg HR,Max HR,Avg Temperature,Calories
1,NMG,1,00:06:08.258,00:06:06.00,1,36,--,0:06:08  ,0:06:06  ,0:04:13  ,175.390625,193.0,92.89507499768523,--,--,--,65
1,NMG,2,00:10:26.907,00:10:09.00,1,129,--,0:10:26  ,0:10:08  ,0:06:02  ,150.140625,236.0,63.74555754497759,--,--,--,55</code></pre>

<p>For user information data we have used the following dataset  </p>

<pre><code>runner,dob,name
JM,01-01-1900,Jon Mead
NMG,01-01-1900,Nelio Guimaraes</code></pre>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-09-at-11.20.42.png" alt="" /></p>

<p>Add your S3 credentials to access <continue></p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-09-at-11.22.14.png" alt="" /></p>

<p>After configuring your S3 account all buckets associated to it, will be prompted under the new source area.</p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-09-at-12.13.12.png" alt="" /></p>

<p>For this post I’ve created two buckets : nmgbuckettest and nmgdremiouser containing data that could be interpreted as a data mart </p>

<p><img alt="Image Description" src="/blog/content/images/2018/07/Screen-Shot-2018-07-10-at-15.42.03.png" style="width: 360px; height:280px"></p>

<p><strong>nmgbuckettest</strong> - contains Garmin activity data that could be seen as a fact table in CSV format :</p>

<p><font size="3">Act,Runner,Split,Time,Moving Time,Distance,Elevation Gain,Elev Loss,Avg Pace,Avg Moving Paces,Best Pace,Avg Run Cadence,Max Run Cadence,Avg Stride Length,Avg HR,Max HR,Avg Temperature,Calories</font></p>

<p><strong>nmgdremiouser</strong> - contains user data that could be seen as a user dimension in a CSV format:</p>

<p><font size="3">runner,dob,name</font></p>

<h3 id="creatingdatasets">Creating datasets</h3>

<p>After we add the S3 buckets we need to set up the CSV format. Dremio makes most of the work for us, however we had the need to adjust some fields, for example date formats or map a field as an integer.</p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-03-at-16.45.58.png" alt="" /></p>

<p>By clicking on the gear icon we access the following a configuration panel where we can set the following options. Our CSV's were pretty clean so I've just change the line delimiter for <code>\n</code> and checked the option <em>Extract Field Name</em></p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-03-at-16.53.02.png" alt="" /></p>

<p>Lets do the same for the second set of CSV's (nmgdremiouser bucket)</p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-03-at-16.54.32-1.png" alt="" /></p>

<p>Click in saving will drive us to a new panel where we can start performing some queries. </p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-03-at-17.41.21-1.png" alt="" /></p>

<p>However as mentioned before at this stage we might want to adjust some fields. Right here I'll adapt the <em>dob</em> field from the nmgdremiouser bucket to be in the dd-mm-yyyy format.</p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-13-at-11.46.55.png" alt="" /></p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-13-at-11.47.30-1.png" alt="" /></p>

<p>Apply the changes and save the new dataset under the desire space. </p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-13-at-11.57.18.png" alt="" /></p>

<p>Feel free to do the same for the nmgbuckettest CSV's. As part of my plan to make I'll call <em>D_USER</em> for the dataset coming from nmgdremiouser bucket and <em>F_ACTIVITY</em> for data coming from nmgbuckettest</p>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-13-at-12.12.11.png" alt="" /></p>

<h3 id="queryingdatasets">Querying datasets</h3>

<p>Now that we have D<em>USER and F</em>ACTIVITY datasets created we can start querying them and do some analysis.</p>

<p>This first analysis will tell us which runner climbs more during his activities:</p>

<pre><code>SELECT round(nested_0.avg_elev_gain) AS avg_elev_gain, round(nested_0.max_elev_gain) AS max_elev_gain, round(nested_0.sum_elev_gain) as sum_elev_gain, join_D_USER.name AS name
FROM (
  SELECT avg_elev_gain, max_elev_gain, sum_elev_gain, runner
  FROM (
    SELECT AVG(to_number("Elevation Gain",'###')) as avg_elev_gain,
    MAX(to_number("Elevation Gain",'###')) as max_elev_gain,
    SUM(to_number("Elevation Gain",'###')) as sum_elev_gain,
    runner
    FROM dremioblogpost.F_ACTIVITY
    where "Elevation Gain" != '--'
    group by runner
  ) nested_0
) nested_0
 INNER JOIN dremioblogpost.D_USER AS join_D_USER ON nested_0.runner = join_D_USER.runner    </code></pre>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-16-at-13.45.01.png" alt="" /></p>

<p>To enrich the example lets understand who is the fastest runner with analysis based on the total climbing </p>

<pre><code> SELECT round(nested_0.km_per_hour) AS avg_speed_km_per_hour, nested_0.total_climbing AS total_climbing_in_meters, join_D_USER.name AS name
FROM ( 
  SELECT km_per_hour, total_climbing, runner
  FROM (
    select avg(cast(3600.0/((cast(substr("Avg Moving Paces",3,2) as integer)*60)+cast(substr("Avg Moving Paces",6,2) as integer)) as float)) as km_per_hour,
        sum(cast("Elevation Gain" as integer)) total_climbing,
        runner
        from dremioblogpost.F_ACTIVITY
        where "Avg Moving Paces" != '--'
        and "Elevation Gain" != '--'
        group by runner
  ) nested_0
) nested_0
 INNER JOIN dremioblogpost.D_USER AS join_D_USER ON nested_0.runner = join_D_USER.runner</code></pre>

<p><img src="/blog/content/images/2018/07/Screen-Shot-2018-07-18-at-13.30.55.png" alt="" /></p>

<h3 id="conclusions">Conclusions</h3>

<p>Dremio is an interesting tool capable of unifying existing repositories of unstructured data. Is Dremio capable of working with any volume of data and complex relationships? Well, I believe that right now the tool isn't capable of this, even with the simple and small data sets used in this example the performance was not great.</p>

<p>Dremio does successfully provide self service access to most platforms meaning that users don't have to move data around before being able to perform any analysis. This is probably the most exciting part of Dremio. It might well be in the paradigm of a "good enough" way to access data across multiple sources. This will allow data scientists to do analysis before the data is formally structured.</p>
                    </section>
                    <div id="disqus_thread"></div>
                        <footer class="post-footer">
                             
                            <section class="gh-subscribe">
                                <h3 class="gh-subscribe-title">Subscribe to Rittman Mead</h3>
                                <p>Get the latest posts delivered right to your inbox.</p>
                                <form method="post" action="/blog/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="Your email address" />
    </div>
    <button class="" type="submit">Subscribe</button>
    <script type="text/javascript">(function(g,h,o,s,t){h[o]('.location')[s]=h[o]('.location')[s] || g.location.href;h[o]('.referrer')[s]=h[o]('.referrer')[s] || h.referrer;})(window,document,'querySelector','value');</script>
</form>


                                <span class="gh-subscribe-rss">or subscribe <a href="http://cloud.feedly.com/#subscription/feed/https://www.rittmanmead.com/blog/rss/">via RSS</a> with Feedly!</span>
                            </section>
                        </footer>
                </article>
            </main>
        </div>
        <div class="col-md-3 sideGhost">
            <aside class="blog-sidebar">
    <section class="author">
        <section class="author">
                             <section class="author">
                    <h3><a href="/blog/author/nelio-guimaraes/">Nélio Guimarães</a></h3>                     <p>Read <a href="/blog/author/nelio-guimaraes/">more posts</a> by this author.</p>
                    <div class="author-meta">
                         
                    </div>
                </section>
       </section>
    </section>
    <section class="share">
        <h3>Share this Post</h3>
        <a class="icon-twitter" style="font-size:25px !important;color:#808080;" href="https://twitter.com/intent/tweet?text=Making%20our%20way%20into%20Dremio&amp;url=https://www.rittmanmead.com/blog/2018/07/untitled/" onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;">
            <span class="hidden">Twitter</span>
        </a>
        <a class="icon-facebook" style="font-size:25px !important;color:#808080;" href="https://www.facebook.com/sharer/sharer.php?u=https://www.rittmanmead.com/blog/2018/07/untitled/" onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;">
            <span class="hidden">Facebook</span>
        </a>
        <a class="icon-google-plus" style="font-size:25px !important;color:#808080;" href="https://plus.google.com/share?url=https://www.rittmanmead.com/blog/2018/07/untitled/" onclick="window.open(this.href, 'google-plus-share', 'width=490,height=530');return false;">
            <span class="hidden">Google+</span>
        </a>
    </section>
    <section class="blogpost-headers">
        <div class="button btn" style="width:100%; color:#fff; font-size:16px;">
            <a style="color:#fff;" href="/blog/tag/technical" style="font-size:16px;">Technical Insights</a>
        </div>
        <div class="button btn" style="width:100%; color:#fff; font-size:16px;">
            <a style="color:#fff;" href="/blog/tag/business-insights" style="font-size:16px;">Business Insights</a>
        </div>
        <div class="button btn" style="width:100%; color:#fff; font-size:16px;">
            <a style="color:#fff;" href="/blog/tag/rittman-mead-life" style="font-size:16px;">Rittman Mead Life</a>
        </div>
    </section>
	<section class="search-field">
        <div class="bm20">
            <h3>Search the Blog</h3>
        </div>
        <script>
              (function() {
                var cx = '011968080232057045375:lx7booyq-8q';
                var gcse = document.createElement('script');
                gcse.type = 'text/javascript';
                gcse.async = true;
                gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
                var s = document.getElementsByTagName('script')[0];
                s.parentNode.insertBefore(gcse, s);
              })();
        </script>
        <gcse:search></gcse:search>
    </section>
    <section>
        <div class="bm20">
            <h3>Sign Up for Our Newsletter</h3>
        </div>
        <div id="mc_embed_signup">
            <form action="//rittmanmead.us10.list-manage.com/subscribe/post?u=e4ade60a8963f96a9c97d0bfc&amp;id=4a160dccbf" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
                <div id="mc_embed_signup_scroll">

                    <input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
                    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
                    <div style="position: absolute; left: -5000px;" aria-hidden="true">
                        <input type="text" name="b_e4ade60a8963f96a9c97d0bfc_4a160dccbf" tabindex="-1" value="">
                    </div>
                    <div class="clear">
                        <input style="width:100%;font-size:16px;" type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button btn">
                    </div>
                </div>
            </form>
        </div>
    </section>
    <section class="recent-posts">
        <h3>Recent Posts</h3>
        <ul class="sidebarLink">
            <li style="font-size:16px;"><a href="/blog/2018/07/untitled/">Making our way into Dremio</a></li>
            <li style="font-size:16px;"><a href="/blog/2018/07/oac-workshop-faq/">Oracle Analytics Cloud Workshop FAQ</a></li>
            <li style="font-size:16px;"><a href="/blog/2018/06/devops-in-oac-scripting-oracle-cloud-instance-management-with-psm-cli/">DevOps in OAC: Scripting Oracle Cloud Instance Management with PSM Cli</a></li>
            <li style="font-size:16px;"><a href="/blog/2018/06/kscope18-its-a-wrap/">Kscope18: It&#x27;s a Wrap!</a></li>
            <li style="font-size:16px;"><a href="/blog/2018/06/chitchat-for-obiee-now-available-as-open-source/">ChitChat for OBIEE - Now Available as Open Source!</a></li>
        </ul>
    </section>
</aside>
        </div>
    </div>
</div>
<aside class="read-next">
    <a class="read-next-story prev no-cover" href="/blog/2018/07/oac-workshop-faq/">
        <section class="post">
            <h2>Oracle Analytics Cloud Workshop FAQ</h2>
            <p>A few weeks ago, I had the opportunity to present the Rittman Mead Oracle Analytics Cloud workshop in Oracle's&hellip;</p>
        </section>
    </a>
</aside>
<script>
/**
* RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
* LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
*/

var disqus_config = function () {
this.page.url = 'https://www.rittmanmead.com/blog/2018/07/untitled/';
this.page.identifier = 'ghost-20699';
};

(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');

s.src = '//rittmanmead.disqus.com/embed.js';

s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>


       <!-- <footer class="site-footer clearfix">
            <section class="copyright"><a href="https://www.rittmanmead.com/blog">Rittman Mead</a> &copy; 2018</section>
            <section class="poweredby">Proudly published with <a href="https://ghost.org">Ghost</a></section>
        </footer>-->
	<footer class="footer inverse-wrapper">
    <div class="container inner2">
        <div class="row">
            <div class="col-sm-4">
                <div class="widget">
                    <h3 class="widget-title">About Us</h3>
                    <p>Hundreds of organizations, from Fortune 500 companies to Ivy Leagues to startups, trust Rittman Mead as a source of knowledge about business intelligence, data, and analytics. What could your business do with the faster, more insightful analytics?</p>
                    <ul class="social naked">
                        <li>
                            <a href="http://www.rittmanmead.com/feed/">
                                <i class="icon-s-rss"></i></a>
                        </li>
                        <li>
                            <a href="http://twitter.com/rittmanmead">
                                <i class="icon-s-twitter"></i></a>
                        </li>
                        <li>
                            <a href="https://www.facebook.com/rittmanmead/">
                                <i class="icon-s-facebook"></i></a>
                        </li>
                        <li>
                            <a href="http://www.linkedin.com/company/rittman-mead">
                                <i class="icon-s-linkedin"></i></a>
                        </li>
                    </ul>
                </div>
            </div>
            <!-- /column -->
            <div class="col-sm-8">
                <div class="col-md-6">
                    <h3 class="widget-title">Get in Touch</h3>
                    <p> <strong>Rittman Mead Consulting Ltd.</strong>
                        <br> Suite B, First Floor,
                        <br> Moore House, 11-13 Black Lion Street,
                        <br> Brighton, BN1 1ND, United Kingdom
                        <br>
                        <br> <abbr title="Phone">P:</abbr> +44 (0) 1273 911 268
                        <br> <abbr title="Email">E:</abbr> info@rittmanmead.com
                        <br>
                    </p>
                </div>
                <div class="col-md-6">
                    <h4 class="widget-title">&nbsp;</h4>
                    <p><strong>Rittman Mead America Inc.</strong>
                        <br> 5280 Avalon Boulevard
                        <br> Alpharetta, GA 30009
                        <br>
                        <br> <abbr title="Phone">P:</abbr> (888) 631-1410
                        <br> <abbr title="Email">E:</abbr> info@rittmanmead.com
                        <br>
                    </p>
                </div>
            </div>
            <!-- /column -->
        </div>
        <!-- /.row -->
    </div>
    <!-- .container -->
    <div class="sub-footer">
        <div class="container inner3">
            <p class="text-center">© 2010 - 2016 Rittman Mead. All rights reserved.</p>
            <p class="text-center"><a href="/privacy-policy/">Privacy Policy</a>&nbsp;&nbsp;|&nbsp;&nbsp;<a href="/cookies/">Manage Your Cookie Settings</a></p>
        </div>
        <!-- .container -->
    </div>
    <!-- .sub-footer -->
</footer>
<script type="text/javascript" src="/js/plugins.js"></script>
<script type="text/javascript" src="/js/scripts.js"></script>
<script defer>
    if (window.update_cookieconsent_options != null) {
    window.update_cookieconsent_options({
        "learnMore": ' Learn More'
        , "message": "This site creates and uses cookies. Click here to"
        , "link": 'http://www.rittmanmead.com/cookies/'
        , "theme": "/css/cookiestyle.css"
        , "container": ".full-layout"
    });

    } else {
    window.cookieconsent_options = {
        "learnMore": ' Learn More'
        , "message": "This site creates and uses cookies. Click here to"
        , "link": 'http://www.rittmanmead.com/cookies/'
        , "theme": "/css/cookiestyle.css"
        , "container": ".full-layout"
    };
    }
</script>
<!-- newsletter code -->
<div id="subscriber-signup" class="newsFooter">
    <div class="row">
                <div class="col-md-10">
                    <h3 style="color:#304049;font-size:2em !important;">Subscribe to Our<br>Monthly Newsletter!</h3>
                </div>
                <div class="col-md-2">
                    <button id="exit-button" style="padding-left:0 !important;">
                        <i class="icon-cancel-circle" style="font-size:20px;color:#1c8ca3;"></i>
                        <div class="divide10"></div>
                    </button>
                </div>
            </div>
    <form action="//rittmanmead.us10.list-manage.com/subscribe/post?u=e4ade60a8963f96a9c97d0bfc&amp;id=4a160dccbf" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
        <div id="mc_embed_signup_scroll">
            <div class="indicates-required bm10"><span class="asterisk">*</span> indicates required</div>
            <div class="mc-field-group">
                <label for="mce-EMAIL" class="newsFormText">Email Address <span class="asterisk">*</span> </label>
                <input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" style="background:#ffffff;"> </div>
            <div class="mc-field-group">
                <label for="mce-FNAME" class="newsFormText">First Name </label>
                <input type="text" value="" name="FNAME" class="" id="mce-FNAME"style="background:#ffffff;"> </div>
            <div class="mc-field-group">
                <label for="mce-LNAME" class="newsFormText">Last Name </label>
                <input type="text" value="" name="LNAME" class="" id="mce-LNAME"style="background:#ffffff;"> </div>
            <div id="mce-responses" class="clear">
                <div class="response" id="mce-error-response" style="display:none"></div>
                <div class="response" id="mce-success-response" style="display:none"></div>
            </div>
            <div style="position: absolute; left: -5000px;" aria-hidden="true">
                <input type="text" name="b_e4ade60a8963f96a9c97d0bfc_4a160dccbf" tabindex="-1" value="">
            </div>
            <div class="divide20"></div>
            <div class="clear">
                <input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button btn">
            </div>
        </div>
    </form>
    <button id="ignore-subscribe" style="padding-left:0 !important;float:right;"><span style="color:#1c8ca3;">Don't Show This Again</span></button>
</div>
<script defer>
    var cookieName = "rm-subscribe-respond"
    jQuery(document).ready(function () {
        //popup window after 3 seconds
        if (screen.width >= 480) {
                if (document.cookie.indexOf(cookieName) == -1) {
		    jQuery("#subscriber-signup").addClass("subscriber-signup-anim");
                }
        }
        //button to close window w/ subscribe and ignore
        jQuery("#mc-embedded-subscribe").click(function () {
            //submit form
            //set cookie
            document.cookie = cookieName + "=true; expires=Wed, 1 Jan 2030 00:00:01 UTC; path=/"
	    jQuery("#subscriber-signup").removeClass("subscriber-signup-anim");
        });
        jQuery("#ignore-subscribe").click(function () {
            //close window and set cookie
            document.cookie = cookieName + "=true; expires=Wed, 1 Jan 2030 00:00:01 UTC; path=/"
	    jQuery("#subscriber-signup").removeClass("subscriber-signup-anim");
        });
        jQuery("#exit-button").click(function () {
	    jQuery("#subscriber-signup").removeClass("subscriber-signup-anim");
        });
    });
</script>
<!-- Heap Tracking Code -->
<script type="text/javascript">
    window.heap=window.heap||[],heap.load=function(e,t){window.heap.appid=e,window.heap.config=t=t||{};var r=t.forceSSL||"https:"===document.location.protocol,a=document.createElement("script");a.type="text/javascript",a.async=!0,a.src=(r?"https:":"http:")+"//cdn.heapanalytics.com/js/heap-"+e+".js";var n=document.getElementsByTagName("script")[0];n.parentNode.insertBefore(a,n);for(var o=function(e){return function(){heap.push([e].concat(Array.prototype.slice.call(arguments,0)))}},p=["addEventProperties","addUserProperties","clearEventProperties","identify","removeEventProperty","setEventProperties","track","unsetEventProperty"],c=0;c<p.length;c++)heap[p[c]]=o(p[c])};
      heap.load("3641204034");
</script>
<!-- End Head Tracking Code -->

    </div>

    <script type="text/javascript" src="https://code.jquery.com/jquery-1.12.0.min.js"></script>

    <script type="text/javascript" src="/blog/assets/js/jquery.fitvids.js?v=b1253d6f60"></script>
    <script type="text/javascript" src="/blog/assets/js/index.js?v=b1253d6f60"></script>

</body>
</html>
